Topics in Cumulus Networks® 1970-01-01T00:00:00Z 502 330 26 60 0 74 7539896 Basic switch config with double trunk between two switches? 2017-06-22T22:17:58Z 2017-06-18T22:37:44Z Thor thor_sigurdsson Hi all,<br /><br />I'm having a bit of a tough time grasping the methodology of Cumulus Linux networking vs. how I'm used to with "simple L2 switches".<br /><br />So here's my question:<br />&nbsp; I have two SuperMicro switches running Cumulus Linux (3.3.1) - freshly installed. These two switches are replacing two older Procurve swithces. These two are located in separate cabinets and trunked together. The procurves with a single trunk, but my plan was to use two of the 4 10Gbit ports on the SuperMicro as trunk ports between the switches.<br /><br />What would be simplest "up and running with NO VLANs (or "default") active at the moment and an active trunk between sw01[swp49,swp50] and sw02[swp51,swp52] ? All interfaces should connect to all other switch ports.. (this is a "I got to get this thing up and running now, and add extra features later" plead :) )<br /><br />Thanks in advance!<br /><br />Thor question 2 2 1 comment 7541609 dhcp fixed address based on chassis serial number 2017-06-21T19:33:42Z 2017-06-21T13:06:48Z cumulusJunkie yemi_salau dhcp fixed address based on chassis serial number<br /><br />We know we can reserve fixed address in&nbsp;isc-dhcp-server based on device mac.<br />IETF shows serial number could be supplied as part of dhcp-client-identifier options in the DHCPREQ.<br />Did cumulus implement this with serial number?<br />The goal is, trying to assign hostname to device based on serial number, using DHCP.<br />If this is not possible, then has anyone done similar thing using ZTP with CUMULUS-SERIAL option within the HTTP-REQ headers? question 1 2 1 comment 7538662 How can see the NetQ GUI with VirtualBox? 2017-06-20T00:44:31Z 2017-06-16T08:47:36Z Jinho_IN4A jinho_kim_7625843 I has download the NetQ for VirtualBox and import the Virtual Machine into my VirtualBox.<br />when i tried to get GUI on web browser with "<a href="" rel="nofollow" title="Link:"></a>" , it didn't connected to my NetQ.<br />would you please give advice how can i see the NetQ GUI correctly? question 6 3 1 comment 7060933 CumulusVX version that will let us use ONIE to install the OS 2017-06-14T06:16:06Z 2016-07-25T15:56:19Z Andrew Coleman andrew_coleman_7489358 Any ETA on the CumulusVX version that will allow us to use ONIE to install (or at least tinker with) installing the OS in a VX VM?&nbsp; I vaguely remember begin told that in a different topic. question 4 3 2 comment 7534480 Is EIGRP suppotred / planned in Cumulus Linux? 2017-06-13T15:47:55Z 2017-06-09T07:32:53Z Sergei Hanus sergei_hanus Is EIGRP protocol supported or planned to be supported on Cumulus Linux?&nbsp;<br />I read about&nbsp;FRRouting and it seems to have some sort of support (<a href="" rel="nofollow"></a>).<br /><br />As an additional question, are there any plans to switch to FRR for Cumulus Linux?<br /><br />&nbsp;Thank you.<br /><br />Sergei. question 3 2 1 comment 7536313 HowTo Configure Breakout Cables 40G => 4x10G Using Cumulus Linux 2017-06-12T22:15:52Z 2017-06-12T22:15:52Z Ophir Maor ophir_maor <p>This post describes how to configure breakout cable 40 =&gt; 10Gb/s using Cumulus Linux OS.</p>This post assumes that you already have Cumulus Linux installed on a Mellanox Spectrum switch.<br /><br /><a href="" rel="nofollow" title="Link:"></a> article 0 1 3 create 7535113 Is there an appetite for merchant silicon to support branch level switching? 2017-06-12T18:28:09Z 2017-06-10T14:03:18Z Mike mike_pfeiffer_dy6yqxd8axebo Has Cumulus considered extending their solution offerings to the branch? &nbsp;I have been evaluating a number of SD-WAN vendors and most of their demos trail off with connecting their product to "some switch" via dot1q sub-interfaces. &nbsp;There is value in being able to connect a switching product to an SD-WAN appliance and be able to benefit from ZTP, automation &amp; orchestration, and PoE. &nbsp;The smallest hardware switch that fits this bill is the&nbsp;AS4610-54P, but even then it is still a bit too much for most branch offices. &nbsp;A more modestly sized appliance at 8 to 24 1 Gbps interfaces that supports PoE on most to all interfaces would be ideal. &nbsp;I could also see a "trimmed" down version of the Cumulus NOS since not at all features that are required for data center operations are needed at the branch... but could be if campus fabrics are considered. idea 3 3 1 comment 7363739 Ansible not able to overwrite the file 2017-06-10T01:32:26Z 2016-11-24T10:26:35Z machiasiaweb machiasiaweb_machi_ma Hello,<br /><br />I following the KB<br /><a href="" rel="nofollow" target="_blank" title="Link https//supportcumulusnetworkscom/hc/en-us/articles/205014637-Ansible-Simple-Playbook-Example-with-a-Quagga-Template"></a><br /><br />to which overwrite quagga config.&nbsp; It got an error <br /><br /># ansible-playbook simple_updatequagga.yml -v<br />Using /root/cumulus_ansible/playbook/ansible.cfg as config file<br /><br />------------------------<br />PLAY [cumulus_vx] **************************************************************<br /><br />TASK [setup] *******************************************************************<br />ok: [cumuslusvx2]<br />ok: [cumuslusvx1]<br /><br />TASK [write the quagga config file] ********************************************<br />fatal: [cumuslusvx2]: FAILED! =&gt; {"changed": true, "failed": true, "msg": "Destination /etc/quagga not writable"}<br />fatal: [cumuslusvx1]: FAILED! =&gt; {"changed": true, "failed": true, "msg": "Destination /etc/quagga not writable"}<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; to retry, use: --limit @/root/cumulus_ansible/playbook/simple_updatequagga.retry<br /><br />PLAY RECAP *********************************************************************<br />cumuslusvx1&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : ok=1&nbsp;&nbsp;&nbsp; changed=0&nbsp;&nbsp;&nbsp; unreachable=0&nbsp;&nbsp;&nbsp; failed=1<br />cumuslusvx2&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : ok=1&nbsp;&nbsp;&nbsp; changed=0&nbsp;&nbsp;&nbsp; unreachable=0&nbsp;&nbsp;&nbsp; failed=1<br />----------------------------------<br /><br />I found the file owner and group is quagga.&nbsp; However, even I tried to add parameters to specify owner, group and mode but still fail<br /><br />====<br />template: src=/root/cumulus_ansible/playbook/quagga.j2 dest=/etc/quagga/Quagga.conf owner=quagga group=quagga mode=0644<br />====<br /><br />Does it have any places caused it got fail?<br /><br />Thanks! question 11 3 1 comment 7521404 iptables connection tracking for the control plane? 2017-06-08T15:29:05Z 2017-05-18T15:40:00Z Chris Marget chris_marget I understand that many iptables features (connection tracking, etc...) are not supported by the underlying switching hardware on switches running Cumulus Linux.<br /><br />It feels like I should still be able to use these features to protect the control plane, but I'm finding that&nbsp;cl-acltool is refusing to install them.<br /><br />Perhaps there's a different way (something other than /etc/cumulus/acl/policy.d) to get these rules installed?<br /><br />Maybe I'm confused and these features can't be used, even on the INPUT/OUTPUT chains?<br /><br />How else are people protecting (filtering, not CoPP) TCP listeners exposed by the control plane? I see that sshd is compiled with libwrap, but I'd feel better with something that's universally applicable (bgpd does not have libwrap) and runs a bit lower in the stack.<br /><br />Thanks! question 8 4 1 comment 7532328 Ansible - Books 2017-06-06T02:13:26Z 2017-06-06T01:49:04Z Juraj Papic juraj_papic Hello,<br />Is there any doc/pdf or video training about Ansible for Cumulus?<br />thanks question 2 2 1 comment 7530945 Ansible Copy 2017-06-05T14:04:17Z 2017-06-03T10:09:11Z Juraj Papic juraj_papic hello<br />I have my playbook that will run a copy of the configuration but Im getting the error,<br />{"changed": false, "failed": true, "module_stderr": "Shared connection to closed.\r\n", "module_stdout": "sudo: a password is required\r\n", "msg": "MODULE FAILURE", "rc": 1}<br /><br />How can i fix it?<br /><br />thanks. question 1 2 1 comment 6983338 Does Cumulus Linux can be used in Dell S4820T Switch and Supports OpenFlow for integrating with SDN Controller? 2017-06-03T05:54:20Z 2016-04-19T14:13:10Z Praveen Kumar praveen_kumar_7867173 Hi, <br /><br />We are considering Dell S4820T for our switching infrastructure. I can see this switch is not in supported hardware list. Let me know this switch is supported. <br /><br />Also, I can see some post says cumulus does not integrate with SDN controllers or supports OpenFlow protocol. Is this is true?. question 12 6 1 comment 7530483 Collecting LLDP information 2017-06-02T13:54:21Z 2017-06-02T13:54:21Z Nick Fisk nick_fisk What does everyone use to collect LLDP information and export it to a graphviz file? I was hoping there might be an easy way to create dynamic network diagrams. question 0 1 1 create 7529595 Cumulus for WAN network 2017-06-02T01:24:38Z 2017-06-01T05:24:51Z Juergen Manthey juergen_manthey <p>Hi, <br /> today we are running a CISCO network based on ASR and 8xx-series routers.<br /> Thinking about future technologies (like SDWAN, 0-Day-installation, automatisation,...)&nbsp; I stumbled on Cumulus. <br /> <br /> Makes it sense to think about, to use Cumulus on "small"-hardware, like Jetway-ITX-boards?<br /> <a href="" rel="nofollow" target="_blank" title="Link http//wwwmini-itxcom/store/JBC390">e.g</a><br /> <br /> Or, did someone already build up a WAN-network (e.g 100 locations, all L2-ethernet) via Cumulus and the "supported" 1G switches?</p><p>Demands would be:<br /></p><p>automation<br /></p><p>vrf-enabled</p><p>policy based routing</p><p>ospf&nbsp;</p><p>qos</p><p> <br /> Greetings<br /> Juergen</p> question 1 2 1 comment 7528975 MLAG connection between different domain of MLAG 2017-05-31T19:44:32Z 2017-05-31T09:42:55Z machiasiaweb machiasiaweb_machi_ma Hello,<br /><br />While studying the Dell power connect manual&nbsp;<br /><br /><a href="" rel="nofollow" title="Link:"></a><br /><br />Figure 2 at page 7.<br /><br />The figure showing the one MLAG domain (2 switch which peerlink together) can be talking to another switch by MLAG.<br /><br />Question<br /><br />Under Cumulus environment. &nbsp;Does it support connect 2 MLAG domain by MLAG? <br /><br />(switch 1 &lt;-peerlink -&gt; switch 2) &nbsp;&lt;---MLAG ----&gt; &nbsp;(switch 3 &lt;---peerlink ----&gt; switch 4)<br /><br />or I need connecting them between by traditional LACP only?&nbsp;<br /><br />Thanks! question 2 3 1 comment