http://m.getsatisfaction.com/topics/7413791/replies/19664607 http://m.getsatisfaction.com/topics/7413791/replies/19473784 19664607 Dennis O'Brien responded to "Ion Exporer outback battery won't charge or A/C power won't do anything" 2018-07-28T03:09:00Z 2018-07-28T03:09:00Z Dennis O'Brien http://m.getsatisfaction.com/people/9739814 https://d2r1vs3d9006ap.cloudfront.net/public/uploaded_images/11304397//platform/profilepic/_medium. dennis_o_brien_hwc7ktsh8kvc3 Same issue with mine. I tried to replace the battery, and when I removed it, the red (+) wire came with it. I opened up the box and found the original connection was s very flimsy, single strand lead into an in-line fuse, with a dab (and that's being generous) of solder holding it to the wire. The lead was to short to service the battery, because all the slack in the line was behind where they had glued the line and insulation in the case. There were strands of glue throughout the case and on the electronics. I fixed those things and checked all connections. Still not charging. I'll go back in tomorrow with a multi- meter, but having built electronics for years with Flextronics, Storage Tek, HP, and SMA, and others, these things couldn't have been built any cheaper. Really guys? The few extra pennies for proper fuse case and connectors, and taking the time in your procedure to make sure the leads are properly placed, wouldn't kill you. 1